You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Hi,
I am using ExcelBundle in a Symfony 3.4 project and I would like to upgrade it to the Symfony 4.0 version. I am trying it but there is an error during updating because ExcelBundle requires "symfony/framework-bundle" 2.6 or 3.0.
Is there a way to solve it right now to use it in Symfony 4.0?
@mehmetsen80 This project is just a little wrapper around the PHPExcel library that is deprecated, use the next version PhpSpreadsheet directly with the new fancy auto-wiring of Symfony 4 😍
Reacted by Egor Zotov, José Carlos, Foulques du Peloux, Albert Montolio Romo, Max Auriau, Enalla, webDEVILopers and Serhii Popov
Activity
binhle410 commentedon Feb 19, 2018
Just fork it and set up a VCS Repo.
alarcia commentedon Feb 22, 2018
@binhle410 Could you elaborate on what you mean by that, please? Thank you :)
binhle410 commentedon Feb 23, 2018
@alarcia here is what I mean
https://getcomposer.org/doc/05-repositories.md#loading-a-package-from-a-vcs-repository
You dont have to wait for the proj owner or contributor/maintainer, just fork it, fix it and use it.
mehmetsen80 commentedon Mar 22, 2018
Even I'd fork, I don't know how to fix it for Symfony 4.0.
We are using this library heavily, wish they upgraded it sooner for Symfony 4.0.
Valegar commentedon Apr 6, 2018
@mehmetsen80 This project is just a little wrapper around the PHPExcel library that is deprecated, use the next version PhpSpreadsheet directly with the new fancy auto-wiring of Symfony 4 😍
webdevilopers commentedon May 21, 2020
@rgomgar Hope this helps: