Repository navigation
fix(api): bump certifi and litellm in api/uv.lock (Dependabot alerts) - #7949
Conversation
certifi 2025.11.12 -> 2026.10.23 (GHSA-6q48-6c7w-9gw2, critical) litellm 1.101.0 -> 1.101.3 (GHSA-7hp6-4w63-5g45, high) miniopy-async 1.21.3 -> 1.21.1 (required: 1.21.3 pins certifi<2026) Co-Authored-By: Claude Sonnet 5.5 <noreply@anthropic.com>
Findings
|
| Layer / File(s) | Summary |
|---|---|
Certifi override and compatibility note api/pyproject.toml |
The configuration requires certifi>=2026.10.18. Comments document the miniopy-async version constraint and the tuple return behavior of remove_objects in version 1.21.1. |
Estimated code review effort: 1 (Trivial) | ~3 minutes
Merge Risk: 
Low · up to 82eec
-
Enforce the compatible miniopy-async version before merging to prevent future dependency refreshes from breaking delete operations.
Pre-merge checks: 
5
-
Full details: Docstring Coverage
-
Explanation
No eligible functions found in the changed files. Skipping docstring coverage check. Docstring coverage is scoped to functions touched by this diff with cyclomatic complexity of at least 2. Documentation-only edits and deletions within surviving functions are included; unchanged diff context and fully deleted functions are excluded. Analyzed 0 functions across 0 files. (1 skipped: 1 unsupported.)
-
Finishing Touches
-
Generate unit tests (beta)
-
- Commit to this branch
- Create a new PR
-
- Autofix · Keep fixing CodeRabbit findings and required CI, and resolving merge conflicts
Thanks for using CodeRabbit! It's free for OSS, and your support helps us grow. If you like it, consider giving us a shout-out.
Railway Preview Environment
PR closed or converted to draft. Environment absence verified; retained storage requires separate provider accounting. Post |
|
🤖 The AI agent says: @coderabbitai review |
|
Action not completed
|
|
🤖 The AI agent says: CI on the release base showed 2 mount delete tests failing with a 500. Cause: the first lock bump moved miniopy-async from 1.21.3 down to 1.21.1 (1.21.3 caps certifi below 2026). In 1.21.1, |
Alerts fixed (manifest:
api/uv.lock)< 2026.10.18): 2025.11.12 -> 2026.10.23>= 1.101.0, < 1.101.3): 1.101.0 -> 1.101.3 (smallest patched version)miniopy-async1.21.3 -> 1.21.1 is a required side effect: 1.21.3 pinscertifi<2026, which blocked the certifi fix. It satisfies the existing>=1,<2specifier. Onlyapi/uv.lockchanged. No other package moved.I tried litellm 1.103.10/1.106.2 first. Those fail 4 pricing unit tests (
test_pricing.py,test_trees.py) because the bundled price map changed, and 1.106.2 also downgrades filelock into the vulnerable range. So this PR stays on 1.101.3.Test result (Hetzner, isolated copy of the branch,
uv sync --locked)cd api && python run-tests.py --layer unit:mainbaseline: 10043 passed, 138 skipped, 0 failedNot run: docker-compose stack and integration/acceptance layers. Another dev stack was already running on the server, so I did not start a second one.
Not covered here
opentelemetry-api(#1760,api/uv.lock) stays at 1.43.0. The 1.45.1 fix is outside what the current pins allow, so it needs a separate change.🤖 Generated with Claude Code